Module Load Exception with DNN 5.2.3

Mar 21, 2010 at 1:47 PM
Edited Mar 21, 2010 at 2:06 PM

Message: DotNetNuke.Services.Exceptions.ModuleLoadException: Der Typ "DotNetNuke.Entities.Content.ContentItem" in der Assembly "DotNetNuke, Version=5.2.3.74, Culture=neutral, PublicKeyToken=null" konnte nicht geladen werden. ---> System.TypeLoadException: Der Typ "DotNetNuke.Entities.Content.ContentItem" in der Assembly "DotNetNuke, Version=5.2.3.74, Culture=neutral, PublicKeyToken=null" konnte nicht geladen werden.bei WatchersNET.CKEditor.Web.CKEditorControl.LoadPageSettings()bei WatchersNET.CKEditor.Web.CKEditorControl.CheckFileBrowser()bei WatchersNET.CKEditor.Web.CKEditorControl.CKEditor_Init(Object sender, EventArgs e)bei System.Web.UI.Control.OnInit(EventArgs e)bei System.Web.UI.Control.InitRecursive(Control namingContainer)bei System.Web.UI.Control.AddedControl(Control control, Int32 index)bei DotNetNuke.UI.UserControls.TextEditor.Page_Load(Object sender, EventArgs e)--- Ende der internen Ausnahmestapelüberwachung ---
Source:
Server-Name: Testserver

Steps to repro:
Install the CKEditor 1.8.0 as new Module (CKHtmlEditorProvider_01.08.00_Install_DNN5). Change the Editor to web.config
DNN Versionhistorie: 4.9.5 Groundinstall (with Language Packages)> 5.2.2 Upgrade (with Language Packages)> 5.2.3 Upgrade

Coordinator
Mar 21, 2010 at 3:25 PM
Edited Mar 21, 2010 at 3:48 PM

Hmh thats a strange error. On Which Module did the error occur?

And i cannot reproduce this behavior, but i tested it with my new version 1.9

Mar 21, 2010 at 10:23 PM

i have make a new install from CKEditor 1.8.0 (downloadet 21. 03. 2010) on testportal (DNN 5.2.3)
You write the Version 1.9 works only with DNN 5.3.0 and higher. I can not test this, sorry.
I am waiting for the new Version DNN 5.3.1 and look again later, ok? Then I'll make a Upgrade of this Module.

Coordinator
Mar 22, 2010 at 2:01 AM
thoeni wrote:

You write the Version 1.9 works only with DNN 5.3.0 and higher. I can not test this, sorry.

 Yes but there are also work with DNN 5.x or 4.x. The Install Zip File Contains 3 Packages. One For 4.x, One for 5.x and one for 5.3.x

Mar 24, 2010 at 10:51 PM

That's what I've done. I took the 5.x version, and this produced the above error... So I don't have version 5.3.0 installed.

Coordinator
Mar 30, 2010 at 11:49 AM

Ok i can reproduce this errror "Der Typ "DotNetNuke.Entities.Content.ContentItem" in der Assembly "DotNetNuke, Version=5.2.3.74, Culture=neutral, PublicKeyToken=null" konnte nicht geladen werden."

This error occurs because you have installed the wrong Install Package you have installed the one for DotNetNuke 5.3. You installed this one CKHtmlEditorProvider_01.09.00_Install_DNN53.zip but you need this one CKHtmlEditorProvider_01.09.00_Install_DNN5.zip