Browse Server not working in DNN 7?

Jan 27, 2013 at 9:12 PM

When browsing the server placing a link for a DNN page, the browse-tree shows only the top two nodes; there's should be at least 10 nodes.  The two nodes that do appear have the little (+) sign to expand, but nothing happens when attempting to expand the nodes.

Everything was working fine until recently.  I wish I could report a new module or other change that might be a clue explaining this behavior, but there have been no major changes.  The problem surfaced with DNN 7.0.0.  I hoped an upgrade to 7.0.2 would help, but that upgrade didn't cause the behavior to disappear.

I tried uninstalling the CKEditor, and re-installing.  That did not help.

This is frustrating (obviously) since links to tabs within the site cannot happen.  Any idea how to fix this?  Thanks very much.  :)

Feb 2, 2013 at 7:26 PM
Which CKEditor Provider Version did you use? This looks like an older Bug, which i already fixed.
Mar 12, 2013 at 11:12 AM
I'm having the same issue since upgrade to 2.00.03 Beta and also to 2.00.04 (DNN 703)
Mar 12, 2013 at 3:23 PM
NumberCrunchy wrote:
I'm having the same issue since upgrade to 2.00.03 Beta and also to 2.00.04 (DNN 703)

The two nodes that do appear have the little (+) sign to expand, but nothing happens when attempting to expand the nodes.
Are there any javascript errors after clicking on the + sign?
Mar 12, 2013 at 8:46 PM
No, there is no JavaScript error.
But it's interesting - the same installation on localhost opens the browser tree properly.
The live server folder permissions are correctly assigned - text editing and saving works well on both installations ...
Mar 14, 2013 at 3:57 AM
Hello tha_watcha & NumberCrunchy --->

---> I've been suffereing with this same problem since early January; you'll notice I started this thread in late January.

The good news is I don't think the problem is with the CKEditor Provider. The exact same symptoms with the CKEditor Provider browse-tree having only two nodes appearing also happens with the DNN Page Management (DotNetNuke.Tabs) module.

Both the Browse Server for the CKEditor and DNN Page Managment module share pretty-much the same appearance when they both work (and when they don't work). The same problem with the Browse Server for the CKEditor described in this thread is about identical in my instance of the DNN Page Management module. Moreover, both problems started happening about the same time.

I've tried uninstalling. then reinstalling, the DNN Page Management module, and trying the Page Management module from DNN Werks, plus uninstalling/reinstalling the CKEditor, but the same problem remains.

So, among my questions now for NumberCrunchy is whether your DNN Page Managment module has the same problem as your CKEditor Provider?

After nearly two months strugging with this problem I still have not discovered a fix. I'm not sure why the system broke, but within only a few minutes of each other back in early January I installed the CKEditor, plus ... maybe very significant ... I also turned-on Friendly URL's for the site. I'm not sure which action caused the failure, but I reversed both actions compeltely without any change to the problem (although I'm religious about back-ups I did not make a back-up before installing the CKEditor, or switching-on the Friendly URL's).

I've posted about this problem on the DNN site a few times. Usually the DNN forums come back with something, but for this issue there've been zero responses. So far, only NumberCrunchy and the reply from the_watcha have been the only interest in these subjects here on CodePlex. Therefore, I'm very curious whether NumberCrunchy has similar experiences with either the DNN Page Management module, or whether there you changed your site to Friendly URL's when you problem started.

Finally, Thank You to the_watcha for your wonderful adaption of the CKEditor to DNN. I much prefer the CKEditor over the Telerik Editor. Hopefully, whatever is causing the problems here can be resolved with the answer helping other DNN users.
Mar 14, 2013 at 9:53 AM

Server installation:
  • DNN Page Management tree opens as expected and mousover hover works, but when you click on a page name, an endless loop started.
  • CK File tree shows only the base node and doesn't respond on any clicks (no mousover hover).
  • CK Page tree shows the base nodes and looses itself in an endless loop by clicking on a page (no mousover hover).
Localhost installation:
Everything works well

Best regards
Mar 21, 2013 at 12:36 PM
No, there is no JavaScript error.
And also no error in the Event Log of DNN?

I don't think that my code and the Code of the Page Management are the same. The only thing thats the same is that both using the DNNTreeview (RadTreeView).

Ether there is something wrong with the Telerik Controls, or there are problems with the JavaScript on the site which conflicts with the tree View Script.

Any chance you could send me login data for your sites (via Mail), to take a look at the site? Otherwise the only option left for would be to replace the Rad Control with a Standard Control, then we would know if that is the problem.
Mar 21, 2013 at 1:57 PM
Yes, tha_watcha, I'd be happy to send you a login for my site. Please send an e-mail to
Mar 21, 2013 at 2:37 PM
Edited Mar 21, 2013 at 2:47 PM
Hello tha_watcha,

I have sent you the access data.

Thank you very much in advance!

I have upgrated a 2nd fully functional DNN6 Site with an older Version of CKEditor (~1.14) to DNN7 directly on the production server. Here occurs the same issue: After updateing to DNN7 the tree doesn't expand anymore ...
Mar 22, 2013 at 3:34 PM
Thx i got the info i logged on and i can see various error messages.

Failed to load resource: the server responded with a status of 404 (Not Found) .../ScriptResource.axd looks like the script is not loaded for the some reasons.

I'm afraid that goes beyond my knowledge. Normally i would think there is a web.config entry missing.

Found this on google

Maybe this helps in your case. Strangely this entries are also missing in my test dnn installation but it works there as expected.

So my only idea right know try to add both entries to the web.config and see whats happening.
Mar 23, 2013 at 12:55 PM
Edited Mar 24, 2013 at 3:17 PM
Thank you so much!!!

The ScriptResource entry, nested under <system.webServer> / <handlers> solved the problem immediately.

If you want to look into the logfiles, you have still access within the next days.

Thank you for your fantastic work!

P.S.: Hopefully also the solution for rightangle.
Oct 29, 2013 at 10:27 PM
I am having this same problem with DNN 7.05

See this thread.

I am unable to expand the + sign to access additonal pages or folders.
Oct 30, 2013 at 11:40 AM
dgambino wrote:
I am having this same problem with DNN 7.05

See this thread.

I am unable to expand the + sign to access additonal pages or folders.
Did you also get the same javascript errors in the error console?
Oct 30, 2013 at 2:29 PM
No. Would you have time to hop on a quick SKYPE?
Oct 30, 2013 at 2:51 PM
Ok, I just did this and it worked for me too.

For those of you that are not very techie, like me. Here are the steps.
  1. Open Web Config for your DNN Host.
  2. Do a search for "<system.webServer>" and then navigate down to the <handlers> area.
  3. Add the line of code below.
  4. Save
  5. Go to Host Settings and clear the cache and restart application.

<add name="ScriptResource" preCondition="integratedMode" verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />

This worked for me.