CKEditor 2.00.09 and Internet Explorer with Custom Styles

Feb 7, 2014 at 6:54 PM
I cannot get any IE version to get working if custom styles are defined. Other browsers work just fine. I receive these script errors:


SCRIPT1002: Syntax error
File: MyStyles.xml, Line: 1, Column: 1
SCRIPT438: Object doesn't support property or method 'selectSingleNode'
File: plugin.js, Line: 78, Column: 5

If i remove custom styles, CKEditor loads just fine. XML file is correct
Coordinator
Feb 8, 2014 at 12:41 PM
Looks like a bug in the xml plugin, nothing i can fix. Use js file type for styles if you want to use IE.
Feb 10, 2014 at 12:38 PM
are you reference to XML plugin in IE or DNN? is anything I can try?
Coordinator
Feb 10, 2014 at 1:12 PM
I mean the xml plugin of the CKEditor, and yes you could try to solve the issue.
Feb 10, 2014 at 7:35 PM
It seams, I cannot make js custom styles to work either. I specified URL to js file in List of available styles.
Coordinator
Feb 10, 2014 at 8:23 PM
Any errors?

Can you post the Content of the js file?
Feb 10, 2014 at 8:34 PM
Edited Feb 10, 2014 at 8:37 PM
I figured it. I have SSL enabled on Login page. The js path was HTTP only, and my browser was suppressing non-secure content prompt. Interesting, specifying the path with HTTPS causes errors if I click "Custom Editor Options". I tried in FF/Chrome/IE..and this time I reset browsers to default settings :)))