Setting text area background color of the WatchersNET CKEditor™ Provider 2.0.10

Feb 27, 2014 at 3:15 PM
As I couldn't find any reference here and my endeavors at setting the background of the text field in the editor through "Custom Editor Options--> Editor CSS" rendered no effect then could someone point me in the right direction as to where to set the text field background color (e.g. "background-color: grey") in CKEditor for DNN as it happens that sometimes I have to edit content in white (color:white) when the background of a module is dark. Of course it's not worth mentioning that white font color is invisible on standard white CKEditor text field.

Any hints are welcome.
Mar 1, 2014 at 11:20 AM
body {background-color: grey} 
use this in the css defined under "Editor area CSS"
Mar 1, 2014 at 12:54 PM
Edited Mar 1, 2014 at 12:54 PM
I'm sorry but I cannot seem to find the Editor area CSS in the Custom Editor Options --> Editor's configuration.
Mar 1, 2014 at 1:34 PM
Greg_Greensky wrote:
I'm sorry but I cannot seem to find the Editor area CSS in the Custom Editor Options --> Editor's configuration.
its on the Tab Main Settings not Editor Config.
Mar 1, 2014 at 2:39 PM
Strange, but that's what I also did originally, i.e. created a css file where I set the body {background-color: grey;} directive, saved the file under the portal root, synced the portal files under the File Management, set the reference for the css file in the Main Settings Tab, saved the settings, refreshed the editor and ... nothing. This setting doesn't work for me.

That's why I asked here where to set this option. It looks there's a bug in CKEditor 2.0.10.
Mar 1, 2014 at 2:49 PM
It works fine in 2.0.11. Did you saved this as portal setting? Are any page settings or module settings saved for that page?

You can check with the dom inspector if that css is actually loaded or if its overridden.
Mar 1, 2014 at 3:37 PM
Strange again that I initially applied the css file only to one specific module on a page but in the end the css file was visible for the whole site (guessing the name only as I have the Polish language version of CKEditor).

The DOM inspector shows nothing interesting except for bgcolor="" and background = "".
The HTML Style tab of Firebug in Firefox shows that nothing is overidden, i.e. background-color: #FFFFFF;

Upgrading to 2.0.11 corrected nothing.
Mar 2, 2014 at 9:21 AM
Check the html source output, if the css is actually loaded in the editor config under contentsCSS, there should be two the default one + your css file.
Mar 2, 2014 at 3:44 PM
OK, just to wrap this long thread I managed to get it working but only after having done many changes to the configuration.
  1. Host --> HTML Editor Manager --> Editor area CSS - set my css file for the whole site
  2. Only when I removed the Editor area CSS reference to my css file on my dev website page in the HTML Editor Manager for particular module did the settings change and the background was set to grey.
It looks as the CK HTML Editor Manager's settings are not synced throughout the same portal.
It would be logical if the changes applied to a HTML module Editor's settings were visible without having to resort to changing the pan-portal settings.

Treat the threat as closed though.