Editor is stripping HTML

Jun 3, 2014 at 7:07 PM
Using v2.0.12 on DNN 7.2.2
The editor is stripping HTML from my modules when opening them up for edit.

Example - HTML module on page contains this:
<ul class="list icons list-unstyled">
    <li><em class="icon icon-check"></em> Design</li>
    <li><em class="icon icon-check"></em> HTML/CSS</li>
    <li><em class="icon icon-check"></em> Javascript</li>
    <li><em class="icon icon-check"></em> Backend</li>
</ul>
and when opening in CKeditor the <em> tags and content are stripped.

Is this some plugin that's doing this? Any way to turn this off?
TIA - Marcus.
Jun 5, 2014 at 6:44 PM
I too, would love to know how to tell CKEditor to quit deleting my HTML.
Coordinator
Jun 8, 2014 at 4:00 AM
amosmax wrote:
Using v2.0.12 on DNN 7.2.2
The editor is stripping HTML from my modules when opening them up for edit.

Example - HTML module on page contains this:
<ul class="list icons list-unstyled">
    <li><em class="icon icon-check"></em> Design</li>
    <li><em class="icon icon-check"></em> HTML/CSS</li>
    <li><em class="icon icon-check"></em> Javascript</li>
    <li><em class="icon icon-check"></em> Backend</li>
</ul>
and when opening in CKeditor the <em> tags and content are stripped.

Is this some plugin that's doing this? Any way to turn this off?
TIA - Marcus.
Yes you can tell the editor to ignore this html...
  1. Log in as Host and Go to Host -> Html Editor Manager or click on the Custom Editor Options under the Editor
  2. Switch to the Editor Config Tab and add the following line under ProtectedSource and save the Settings, and reload the Editor Page.
[( /<em class[\s\S]*?>/g ),( /<\/em>/g )]