1
Vote

Users in Child Portals cannot upload images with File Browser in 2.01.06

description

Running DNN 8.0.4 and CKEditor Provider 2.01.06

Users in a Child Portal, even Administrators, cannot upload files using the File Browser.

However, if the user is also added to the Parent Portal, even as just a Registered User, the upload works in the Child Portal for that user.

comments

djamell wrote Feb 4 at 3:17 PM

I continue to struggle with this on a site with one Parent and 30 Child Portals.

Any advice, Ingo?

tha_watcha wrote Feb 5 at 6:21 PM

With no upload you mean the user no can see the upload button?

I tried to reproduce the problem without success uploads are working, with the default upload folder!

Or did you specify a custom upload folder?

djamell wrote Feb 6 at 2:31 PM

I created a "screencast" video made with TechSmith Jing to demonstrate:

https://www.screencast.com/t/iiQFiDiJPF

The user also gets logged out which makes me think this might be a problem with URLs

djamell wrote Feb 8 at 6:47 PM

Were you able to view the video?

Let me know if you have other questions.

tha_watcha wrote Feb 8 at 7:39 PM

No sorry i no have flash

djamell wrote Feb 8 at 8:14 PM

OK, sorry about that.

As an Administrator in a Child Portal, when I open the file browser and navigate to a folder and upload a file the upload shows completed, but when I drop back the File Broswer, nothing is there.

At that point, I sometimes get a pop p that says "Not Authorized", but I am always logged out.

If I make that same user a Registered User in the Parent Portal, everything works

djamell wrote Feb 15 at 5:26 PM

In the web.config I changed the DNNFriendlyUrlProvider to "advanced" and the Child Portal Administrative User is no longer logged out when they try to upload an Image using the File Browser.

ALSO, I found that the file browser WORKS when the Modus is File.

But, as before, if the File Browser is in Modus Image, and the User is in the Administrative Role of a Child Portal, the image does not upload.

After the upload finishes and the user is returned to the File Browser the image is not there. No errors on screen, or in the DNN Event Veiwer.

If the same User is added to the Parent Portal, as even a Registered User, the images are uploaded.

djamell wrote Mar 21 at 2:24 PM

Is there anything else I can do to help troubleshoot this issue?

I'm probably going to loose a large account because of this problem.

Whirler wrote Mar 29 at 7:52 PM

I just reported an issue -- from what I can see, there is a file missing in the latest download that is causing the file browser to not displaying correctly. See what I am talking about in that separate issue.

Also, I noticed after first installing this that in the Host > HTML Editor Manager the upload limit is set to -1 for administrators. This made it impossible to upload anything as an administrator. I changed this to 10000000 and that seems to fix that issue. Not sure if that could cause the issue you are seeing?

djamell wrote Mar 29 at 10:09 PM

No, I don't think I'm having the same problem.

My File Browser works fine, except when used in child portals

djamell wrote Mar 30 at 12:21 PM

Please let me restate the problem in as few words as possible.

I'm running DNN 8.0.4 and CKEditor Provider 2.01.06

A User that ONLY exists in a Child Portal, even Administrators, cannot upload IMAGES using the File Browser in Modus Image.

However, if the same User is also added to the Parent Portal, even as just a Registered User, the IMAGE upload works in the Child Portal for that user.

tha_watcha wrote Mar 30 at 1:13 PM

Yes i can reproduce the logout issue. But i dont know what is causing this yet. I need to look in to it.

tha_watcha wrote Apr 15 at 9:15 PM

this is frustrating today i tried find the problem why the user is logged out and the upload doesnt work. But i no had success so far.

djamell wrote Apr 16 at 12:31 PM

One thing I found is there are no problems if the Modus is "File".