Odd behavior when CKEditor made invisible

May 15, 2010 at 6:53 AM
Edited May 15, 2010 at 8:17 AM

First off let me say that I appreciate all of the effort put into building this provider.  It's a shame that the DNN project that's supposed to maintain the FCK provider pretty much died years ago.

I have a CKEditor in an Asp:Panel control.  I want the editor to be invisible when I start the page and turn visible when I make a selection in a grid.  This works fine.  However, if I do a postback at this point, all of the CKEditor toolbars are gone and not much remains.  I can fix this by clicking the "Refresh Editor" link below the TextArea and then it will be OK for one more postback.

The "Refresh Editor" link seems to fix a lot of the problems with CKEditor and this provider.  Is there a way to call that in server side code?

 

Thanks,

BK

May 15, 2010 at 4:41 PM

The Code of the "Refresh Editor" just Reloads the Page with an

 HttpContext.Current.Request.RawUrl

But i think the better Way would been to fix this issue.

I tried to reproduce the behavior, but on my tests it worked, i assume you use the latest version of the editor provider 01.10.02? And check if the jQuery Adapter is on/off

May 15, 2010 at 10:30 PM

I'd love to fix it rather than work around it - thanks!

For whatever it's worth - this editor is part of the edit control in a DNN module.  As such it's part of an ascx file.

I tried setting the jQuery adapter on and off with no change in behavior.  I am happy to provide you with admin access to my staging site if that would help with the troubleshooting.  Just send me email.

 

Thanks,

BK

 

May 15, 2010 at 11:22 PM

I think I solved this one.  I had the edit control of this DNN module set to support Partial Rendering.  When I removed that checkbox I no longer had this issue - the CKEditor toolbars show up each time - every time.

Thanks for your support,

BK