Slow loading of link browser

Aug 17, 2012 at 6:46 AM

Hi Ingo,

I have an issue with the file browser pop-up of a client (not their own server).
The pop-up of the file browser loads so slow it's kind of unusable especially if you have to edit a lot of links. Maybe you have an idea why or how to solve this?

Set-up: DNN 5.6, CKEDIT 1.14.5
Files: there are around 300 files in the portals root (mostly pdf's)

I already set the links tab to show first and turned auto create icons off.

Timing:

First load of pop-up after clicking "browse Server": 12 seconds.
Switch from "Page link" to "File link": 9.5 seconds

You can imagine that's gets frustrating...

BTW, if I go to files in the DNN file manager, the page loads in 2 seconds, so I don't think it's  the amount of files.

I also noticed something else (I guess not related).

If I load the links tab, I get a whole list of 404 errors (around a 100) on images (still in the Links Tab) in Firebug in the NET panel.
Example:

"NetworkError: 404 Not Found - http://www.mysite.nl/Providers/HtmlEditorProviders/CKEditor/Browser/Paginafotos/Gesneden%20paginafotos%202/Locatie%20Goes%20(5)%20(gesneden).jpg"

Any ideas?

Aug 19, 2012 at 11:23 AM

The difference between the dnn file manager and my browser is i do parse each file in order to show additional file info. I am already aware of that problem. I need to make that optional or remove it completely.

Currently iam working 7 days a week on my main job so i dont have that much time. But as soon as i have some free time i am looking for more spots where i can optimize the loading time.

Aug 20, 2012 at 7:25 AM

Ok, sounds good. Thanks.

Aug 20, 2012 at 7:27 AM

BTW Working 7 days a week does not sound good, but the fact that you'll work on the "issue" when you have time does :-)

Aug 26, 2012 at 7:21 AM

Ok new Release is out i think i found the Problem is related to the Thumbnails which takes a lot of time to parse when the setting "Auto Create Image Thumbnails for Preview" is enabled, in the last versions even when the setting is disabled it slows down the loading. This Problem should be gone in the Current Release When you disable that Option, which should be disabled by default.

Aug 31, 2012 at 7:15 AM

Ok, cool. Will test it ASAP, thanks. (I don't have access to the server now)

Sep 18, 2012 at 5:05 PM

Ok, I finally did a new test and it seems a bit better, but the file browser still loads really slow in the 01.14.06 release.

This is what I did to test (on my local machine):
I dumped 2048 photos in the root of the portal (in total around 2GB).

This seems extreme but is almost the situation on the clients server and this did work with the RAD editor (kind of, but a lot of other things did not work with RAD)

I synced the file system.

I set the editor to show the page links first.

With this set-up, the file browser takes 45-50 seconds to load.

Switching to the files tab takes about 50 seconds again.

Switching to the list view does not make a lot of difference for the load time.

BTW, I hear the hard-disk rattling all the time that the file browser is loading..

I then moved the files to a folder called images and re-synced the file system.

I opened the file browser from the editor and now the file browser loads in 2 seconds.

I think there is still some code accessing the files..?

Thanks, Timo

 

 

 

Sep 19, 2012 at 3:21 PM

Is the Auto Create Thumbnail option deactivated in the Options?

The only thing which actually access the file is a check if the file really exists on the file system (I remove that in the next version because there is always a folder sync when viewing a folder).

The rest of the code isn't accessing the file on the server. I have to check if the File Exists check is the problem.

Sep 19, 2012 at 8:40 PM

Yes, Auto Create Image Thumbnails for Preview: was off.

I guess the file exists check could be the issue.

Sep 20, 2012 at 3:26 PM

Ok it was not the File exists check. But i found the problem its the synchronize function. Every time a folder is loaded i sync it before loading the files to make sure all files are loaded. This works fine with only a few files but its not a solution for a large amount of files.

Now i have to think about a better solution...

1. Only manually sync by adding a "Sync Folder" Button just like in the DNN File Manager

2. Or i make an option "Automatically Sync Folder"

3. Integrate both

 

 

Sep 20, 2012 at 3:47 PM

Ok, thanks for looking at this.

I would only add a manual sync button.
Normally all files should be in sync unless a user added or deleted files outside DNN.

And people who do that most likely know enough about DNN to know they should sync the file system manually.

Also the "other" editors don't do an auto-sync, so people don't really expect the editor to do that.

I understand why you added it, but as it makes this great editor feel slow, I would make the "manual sync" the default option.

Thanks, Timo

Oct 11, 2012 at 2:14 PM

Ingo,

I know this is a volunteer job for you so I'm not trying to push you just a question. I can imagine you don't have time, I just want to let my client know what the situation is.

Do you have an idea when you could have a look at this?

If you don't have time I will have to switch back the client to RAD as this is not working for them..

Oct 11, 2012 at 2:44 PM
timo_design wrote:

Ingo,

I know this is a volunteer job for you so I'm not trying to push you just a question. I can imagine you don't have time, I just want to let my client know what the situation is.

Do you have an idea when you could have a look at this?

If you don't have time I will have to switch back the client to RAD as this is not working for them..

 

I am working on the next Major Release V2 including CKEditor 4, but it Takes some Time to put everything together. But i can Release a maintenance release on the weekend including ckeditor 3.6.5 which was released today.

Oct 12, 2012 at 9:44 AM

Ok, thanks a lot!

Oct 13, 2012 at 12:41 PM

New Version is online now. Auto sync is removed and i added an "Sync Folder" Button for manually syncing (Button is only visible for users that have write permission to the folder)

 

http://dnnckeditor.codeplex.com/releases/view/96205

Oct 15, 2012 at 10:09 AM

Ok, great. Will test it today.

Oct 15, 2012 at 7:49 PM

I just tested it and noticed 3 things:

A. I get an error after clicking on "Browser server":

Parser Error

Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.

Parser Error Message: The server tag is not well formed.

Source Error:

Line 262:                    <asp:LinkButton runat="server" ID="FileListItem" CssClass="FilesListItem" 
Line 263:                       CommandArgument='<%# DataBinder.Eval(Container.DataItem, "FileId").ToString()%>'>
Line 264:                      <asp:Image runat="server" ID="FileThumb" CssClass="FilePreview" ImageUrl='<%# DataBinder.Eval(Container.DataItem, "PictureURL").ToString()%>'
Line 265:                          AlternateText="<%# DataBinder.Eval(Container.DataItem, "FileName").ToString()%>" ToolTip="<%# DataBinder.Eval(Container.DataItem, "FileName").ToString()%>" />
Line 266:                      <span class="ItemInfo"><%# DataBinder.Eval(Container.DataItem, "Info").ToString()%></span>


Source File: /Providers/HtmlEditorProviders/CKEditor/Browser/Browser.aspx    Line: 264


Version Information: Microsoft .NET Framework Version:2.0.50727.4223; ASP.NET Version:2.0.50727.4223

I'm testing on DNN 6.1.5 (upgraded from DNN 5) in a child portal of http://dnnmoduletest
Any idea, what could be the error?

B. The DNN5 install file seems to be missing from the complete install package.

C. On installing the text still says:

CKEditor 3.6.4 Html Editor Provider 1.14.06 - For DotNetNuke® 06.00.00 (or higher)

 

Thanks, Timo

Oct 15, 2012 at 11:12 PM

Ah sorry, looks like i uploaded the wrong zip file. I updated the download files now everything should be correct.

Oct 16, 2012 at 1:37 PM
Edited Oct 16, 2012 at 1:38 PM

Ok, I tested it works much better!

I did not notice any slow loading times any more

Obviously when I set the paging to 25, otherwise the page loads slow again, because of the number of images to load (2GB) by the browser.

Thanks a lot!