Users can't upload images

Feb 20, 2013 at 11:34 AM
Hi, when I sign in as an admin I am able to use CK editor to upload images using the upload button, however when I log in as a user although I can still use the images button the upload button doesn't show at all. Can anyone please help me get it to work?

I'm using CK editor 2.0.0 with DNN 6.2.1.

Thanks.
Feb 20, 2013 at 1:12 PM
jackalds wrote:
Hi, when I sign in as an admin I am able to use CK editor to upload images using the upload button, however when I log in as a user although I can still use the images button the upload button doesn't show at all. Can anyone please help me get it to work?

I'm using CK editor 2.0.0 with DNN 6.2.1.

Thanks.
You need to specify which roles are allowed to upload files. Under the Editor there is a Button "Custom Editor Options" to open the Settings (When you logged in as host). On the "File Browser Settings" Tab you can define which roles have access to the file browser under "Allowed Roles".
Feb 20, 2013 at 1:18 PM
Thanks that works, but ideally I just want them to be able to upload from their own computers rather than have access to the files in the Portal. Is there anyway I can just enable the upload button rather than the file browser?
Feb 20, 2013 at 1:27 PM
Also, although they can get into the File Browser all of the options at the top are greyed out. Just can't seem to find anywhere to enable them, I've checked the folder permissions and they are ok but can't think of anywhere else to look.
Feb 20, 2013 at 1:29 PM
jackalds wrote:
Thanks that works, but ideally I just want them to be able to upload from their own computers rather than have access to the files in the Portal. Is there anyway I can just enable the upload button rather than the file browser?
No that's not possible at the moment, but you can enable user folders so users can only see there own folder.
Feb 20, 2013 at 1:32 PM
jackalds wrote:
Also, although they can get into the File Browser all of the options at the top are greyed out. Just can't seem to find anywhere to enable them, I've checked the folder permissions and they are ok but can't think of anywhere else to look.
Which options do you mean. The create folder and upload folder button are only enabled when the current user has write access to the folder. And the download/ delete file buttons are only available when a file is selected. And the resize image button is only available when an image file is selected.
Feb 20, 2013 at 1:33 PM
Hmmm, is there any way I can let them upload their own images?
Feb 20, 2013 at 1:37 PM
The user has Full Control of the folder (set via File Manager) but in the File Browser all the options (create folder, synchronize folder, upload a new file, download a file, etc...) are all greyed out.
Feb 20, 2013 at 1:39 PM
jackalds wrote:
Hmmm, is there any way I can let them upload their own images?
The problem when allowing users only the upload function there is no way that they could select files from a previous upload. That's why there is the file browser with limited functions for regular users, and with the user folders enabled they can access there own files only.
Feb 20, 2013 at 2:49 PM
I think i've solved the problem, I didn't have the right permissions set after all.

Can I ask one last question, where can I set the file types that the user is allowed to upload?
Feb 21, 2013 at 12:29 PM
jackalds wrote:
I think i've solved the problem, I didn't have the right permissions set after all.

Can I ask one last question, where can I set the file types that the user is allowed to upload?
It inherits the allowed file types from dnn under Host Settings -> Other Settings -> Allowable File Extensions.
Mar 10, 2014 at 6:37 PM
tha_watcha wrote:
jackalds wrote:
I think i've solved the problem, I didn't have the right permissions set after all.

Can I ask one last question, where can I set the file types that the user is allowed to upload?
It inherits the allowed file types from dnn under Host Settings -> Other Settings -> Allowable File Extensions.
I have a question about this. You said that it inherits the allowed file types from host settings, however when i look at my allowed file types under host settings there are about 30 extensions in there, including PDF. I'm not seeing that.

I have CKEditor set to provide users individual folders to a location that i specified. When a non-admin tries to upload an image, the upload file window specifically states "the allowed file types are: "bmp,gif,jpeg,jpg,png""

I'm trying to allow PDF upload. I can't seem to find anywhere to change the allowed extensions.
Mar 10, 2014 at 10:04 PM
Well of course that can Not work from the Image Dialog you can only Upload Images, and pdf files are not Images. You can only Upload PDF files and other files from the link Dialog.
Mar 11, 2014 at 6:10 AM
Well you didn't need to make me feel entirely stupid :-) just kidding

That was a result of my brain being on vacation still. It makes sense now. Thanks!