Problem with span elements

Feb 12, 2015 at 2:16 PM
Hi,

I am switching to CKEditor on a new project. I am on DNN 07.03.02 and CKEditor 2.1.0.
Each time I open CKEditor an additional </span> is added for each <span> element that exists. This also happens each time I go in and out of source view and Basic Text Box. I also found that the same thing occurs with the <em> element.

So if I have an html module with only:
<span></span>

When I open it in CKEitor I have:
<span></span></span>

If I save and open it again I have:
<span></span></span></span>

Is there a fix I can apply for this.
Thanks
Rut
Feb 12, 2015 at 2:49 PM
The issue with <em> is a little different. If I have a single <em> in a document each time I open it some of the other elements get <em> around them. I have inserted 3 images to explain. first one has a single <em> near the top. Second is with one save and open. Third is after another save and open.

Image


Image


Image
Feb 12, 2015 at 10:01 PM
Try 02.01.01 Beta 1 this isssue should be already fixed.
Feb 13, 2015 at 12:54 AM
Edited Feb 13, 2015 at 1:07 AM
I upgraded to 02.01.01 Beta 1. I am still seeing the same issues with span and em. When I click help within the editor it reports that it is CKEditor 4.4.6 (revision 08188c4).
I also tried uninstalling both the module and provider and then reinstalled. It did not help.

Thanks For Your Help
Feb 13, 2015 at 1:23 AM
Update. I cleared browser cache and now CKEditor is reporting version 4.4.7 is being used. But I am still seeing the em and span issue.
Thanks
Feb 14, 2015 at 12:50 PM
Fixed. I applied the configuration change to the "Protected Source" setting that is suggested in the comments to Issue #3939. That fixed the problem for me.
Thanks
Feb 16, 2015 at 11:24 PM
Can you explain where you found the fix for this? I try to find issue 3939 and it doesn't appear to be active or able to get to. I'm having something different happening where when trying to use the text highligh, only span tags are inserted with no command to go with it.
Feb 17, 2015 at 12:02 AM
I typed the wrong number. It is #7939. It is a closed item. https://dnnckeditor.codeplex.com/workitem/7939