Configuration

May 1, 2015 at 4:14 PM
Hello,

I have a few issues using the CKEditor within the DNN 7.4 community edition.

When opening a form containing the editor, I sometimes I get the following message:
AN AUTO SAVED VERSION OF THIS CONTENT [DATE TIME] has been found. Would you like to compare content version and choose which one to load?
Is there anyway to suppress this? I'm saving to the database and don't need this option.

When I try to paste into the editor I get the following message:
"Because of your browser security settings, the editor is not able to access your clipboard data directly. You are required to paste it again in this window.
Please paste inside the following box using the keyboard (Ctrl/Cmd+V) and hit OK"
Is there anyway to eliminate this? Or, which browser settings do i need to change?

I'm unable to set the height, the height attribute has no effect:
<dnn:texteditor id="DNNEDITCONTROL" ClientIDMode="Static" runat="server" height="400px" width="100%"></dnn:texteditor>
width works fine. I can however set the height from the form 'CKEditor Provider Settings', but would like to set the height differently for a number of editor instances on a form.

Is it possible to hide certain buttons from the toolbar? I've looked at the configurations files (CKToolbarSets.xml, CKToolbarButtons.xml, CKEditorSettings.xml) under Portals/0
and also at the settings form 'CKEditor Provider Settings' but can't see a way to hide individual buttons.

Best Regards,

Steve
May 1, 2015 at 5:34 PM
Another strange issue is caused by clicking the 'source' button. I can click the button once to display the underlying html, but when I click it for the second time to return to the rich text layout it causes my form to 'jump' off the screen. I can get the form back on the screen using 'shift + tab', but can't expect a user to know that.

Is there a solution to this?

Best Regards,

Steve
May 2, 2015 at 11:36 AM
Edited May 2, 2015 at 11:36 AM
Hello Stephen, the auutosave issue is in fact a plugin you can disable buy removing it from the list of plugins that are loaded by default. In the CKEditor settings go to the tab Editor Config and browse down to ExtraPlugins. You will see that Autosave is listed there. If you remove it and update it should no longer show.

Pasting into the editor is by prohibited by most browser and is not really something that has to do with CKEditor nor the DNN provider. You can change this behaviour but I would not do that. In IE you can change copy and paste settings on the security tab but it is deeply hidden.

Regards
Mariëtte
May 2, 2015 at 11:39 AM
For the toolbars I would create a new toolbar with precisely the buttons you need and apply that to whatever page/tab/module/security group you wish
May 2, 2015 at 1:14 PM
Stephen100 wrote:
Another strange issue is caused by clicking the 'source' button. I can click the button once to display the underlying html, but when I click it for the second time to return to the rich text layout it causes my form to 'jump' off the screen. I can get the form back on the screen using 'shift + tab', but can't expect a user to know that.

Is there a solution to this?

Best Regards,

Steve
Which module or does this happening with all modules?
May 2, 2015 at 1:28 PM
Stephen100 wrote:
When opening a form containing the editor, I sometimes I get the following message:
AN AUTO SAVED VERSION OF THIS CONTENT [DATE TIME] has been found. Would you like to compare content version and choose which one to load?
Is there anyway to suppress this? I'm saving to the database and don't need this option.
You can ether remove the plugin completly or add the button id that saves the content to the setting

Stephen100 wrote:
When I try to paste into the editor I get the following message:
"Because of your browser security settings, the editor is not able to access your clipboard data directly. You are required to paste it again in this window.
Please paste inside the following box using the keyboard (Ctrl/Cmd+V) and hit OK"
Is there anyway to eliminate this? Or, which browser settings do i need to change?
That message is a misleading, because there is now workaround for that, the only way around that is to use the keyboard short cuts as suggested in the message.

Stephen100 wrote:
I'm unable to set the height, the height attribute has no effect:
<dnn:texteditor id="DNNEDITCONTROL" ClientIDMode="Static" runat="server" height="400px" width="100%"></dnn:texteditor>
width works fine. I can however set the height from the form 'CKEditor Provider Settings', but would like to set the height differently for a number of editor instances on a form.
Well you can set the settings for each editor instance individually even if there are more then one editor on a page.

The reason why the control attribute is ignored because it is only used when there is no value found in the editor settings.

Stephen100 wrote:
Is it possible to hide certain buttons from the toolbar? I've looked at the configurations files (CKToolbarSets.xml, CKToolbarButtons.xml, CKEditorSettings.xml) under Portals/0
and also at the settings form 'CKEditor Provider Settings' but can't see a way to hide individual buttons.
Of course you can ether via the included Toolbar Editor inside the Settings window or you modify the CKToolbarSets.xml directly. A little explanation in to that buttons inside the toolbar are grouped as toolbarsets, the toolbar sets are loaded based on the user role. So if you want to modify the toolbars you can ether modify the existing toolbar sets, or create your own one depending on your needs.
May 2, 2015 at 1:40 PM
MarietteNL wrote:
Hello Stephen, the auutosave issue is in fact a plugin you can disable buy removing it from the list of plugins that are loaded by default. In the CKEditor settings go to the tab Editor Config and browse down to ExtraPlugins. You will see that Autosave is listed there. If you remove it and update it should no longer show.

Pasting into the editor is by prohibited by most browser and is not really something that has to do with CKEditor nor the DNN provider. You can change this behaviour but I would not do that. In IE you can change copy and paste settings on the security tab but it is deeply hidden.

Regards
Mariëtte
Hello Mariëtte,

Thank you for your reply. I've successfully disabled autosave from your instructions. Thank you again. Steve
May 2, 2015 at 2:21 PM
Stephen100 wrote:
I'm unable to set the height, the height attribute has no effect:
<dnn:texteditor id="DNNEDITCONTROL" ClientIDMode="Static" runat="server" height="400px" width="100%"></dnn:texteditor>
width works fine. I can however set the height from the form 'CKEditor Provider Settings', but would like to set the height differently for a number of editor instances on a form.
Well you can set the settings for each editor instance individually even if there are more then one editor on a page.

The reason why the control attribute is ignored because it is only used when there is no value found in the editor settings.
I have a module containing several instances of the ckeditor. I would like to be able to set the height for each instance on the module. Removing the height value in the portal editor settings, would affect the settings in all modules wouldn't it? And removing it for module editor settings only works for that instance of the module.

Is there anyway to set the height for each instance of the editor in a given module? In other words, so that when the module is installed each instance of the editor is set to it's required height.

Best Regards,

Steve
May 2, 2015 at 2:27 PM
tha_watcha wrote:
Stephen100 wrote:
Another strange issue is caused by clicking the 'source' button. I can click the button once to display the underlying html, but when I click it for the second time to return to the rich text layout it causes my form to 'jump' off the screen. I can get the form back on the screen using 'shift + tab', but can't expect a user to know that.

Is there a solution to this?

Best Regards,

Steve
Which module or does this happening with all modules?
This only seems to happen with a module that I've developed. Seems to be fine with the html module. Is there a setting that would cause this effect. The only thing I can think of to do is to compare the settings between my module and the html module.

Best Regards,

Steve
May 2, 2015 at 2:39 PM
Thinking about the height, shouldn't it be the other way around. I mean if there's no height in the markup then the editor setting values are used, with some kind of default if the setting is removed or removing it is disallowed. That would allow heights to be set for instances of the editor within a given module but also allow for defaults at portal, page and module level. Just a thought.
May 2, 2015 at 2:48 PM
Stephen100 wrote:
Is there anyway to set the height for each instance of the editor in a given module? In other words, so that when the module is installed each instance of the editor is set to it's required height.
Yes of course simply save the configuration as Module Instance
May 2, 2015 at 2:57 PM
Stephen100 wrote:
tha_watcha wrote:
Stephen100 wrote:
Another strange issue is caused by clicking the 'source' button. I can click the button once to display the underlying html, but when I click it for the second time to return to the rich text layout it causes my form to 'jump' off the screen. I can get the form back on the screen using 'shift + tab', but can't expect a user to know that.

Is there a solution to this?

Best Regards,

Steve
Which module or does this happening with all modules?
This only seems to happen with a module that I've developed. Seems to be fine with the html module. Is there a setting that would cause this effect. The only thing I can think of to do is to compare the settings between my module and the html module.

Best Regards,

Steve
No this is no setting issue looks more like a CSS or JS issue, but without taken a look at it myself i cant help much
May 2, 2015 at 4:50 PM
tha_watcha wrote:
Stephen100 wrote:
tha_watcha wrote:
Stephen100 wrote:
Another strange issue is caused by clicking the 'source' button. I can click the button once to display the underlying html, but when I click it for the second time to return to the rich text layout it causes my form to 'jump' off the screen. I can get the form back on the screen using 'shift + tab', but can't expect a user to know that.

Is there a solution to this?

Best Regards,

Steve
Which module or does this happening with all modules?
This only seems to happen with a module that I've developed. Seems to be fine with the html module. Is there a setting that would cause this effect. The only thing I can think of to do is to compare the settings between my module and the html module.

Best Regards,

Steve
No this is no setting issue looks more like a CSS or JS issue, but without taken a look at it myself i cant help much
OK thank you for your replies. That's a tricky one for me, not sure how to track it down. A JS debugger perhaps.