Errors!

Jan 3, 2010 at 5:12 PM

I found the following erros when trying to use  Custom Editor Options  the page is redirected from the http://www.arabavia.com/Providers/HtmlEditorProviders/CKEditor/Options.aspx?mid=540&tid=59&minc=txtContent to http://www.arabavia.com/Default.aspx?tabid=226&error=The+given+key+was+not+present+in+the+dictionary. and i get the following message:

  A critical error has occurred.
The given key was not present in the dictionary.

 

and another error when I try to upload images, I get the following:

 

Server Error in '/' Application.
--------------------------------------------------------------------------------

Parser Error
Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.

Parser Error Message: Could not load type 'WatchersNET.CKEditor.Browser'.

Source Error:


Line 1:  <%@ Page language="c#" Codebehind="Browser.aspx.cs" AutoEventWireup="false" Inherits="WatchersNET.CKEditor.Browser" %>
Line 2:  <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
Line 3:  <html xmlns="http://www.w3.org/1999/xhtml">
 

Source File: /Providers/HtmlEditorProviders/CKEditor/Browser/Browser.aspx    Line: 1


--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:2.0.50727.4200; ASP.NET Version:2.0.50727.401

 

 

Jan 4, 2010 at 10:48 AM

Did you updated all files from the last release? Because in the newest Browser.aspx the first line look like this.

<%@ Page language="c#" Codebehind="Browser.aspx.cs" AutoEventWireup="false" Inherits="WatchersNET.CKEditor.Browser.Browser" %>

Jan 5, 2010 at 4:06 PM

thanks for ur reply it is a great product! i love it

it is also great for RTL

indeed i installed the latest CKHtmlEditorProvider_1.2.01_Install. for DNN 5 and also reinstalled (repaired) again and even tried it on all browsers but no luck! :((((((

Jan 6, 2010 at 10:18 AM

Sorry i think i didn´t update all files in the install.zip can you please re download the Files, Its updated now.

Jan 6, 2010 at 4:26 PM

sorry to bother u again but i tried the latest 1.3.00

and still getting an erros wheen i open the Custom Editor Options

At first the window opens at:

http://arabavia.com/Providers/HtmlEditorProviders/CKEditor/Options.aspx?mid=822&tid=226&minc=txtContent

then it is redirected to:

http://arabavia.com/Default.aspx?tabid=226&error=The+given+key+was+not+present+in+the+dictionary.

and receive the following message:

A critical error has occurred.
The given key was not present in the dictionary.

 

I can now upload image and that is great!

 

Jan 6, 2010 at 5:03 PM

sorry i will fix this problem tomorrow

Jan 6, 2010 at 5:10 PM

a million thanks!

I am in love with this editor

u did a great job for the DNN community and will make a posting soon to that effect in the dotnetnuke forums!

job well done

 

Jan 7, 2010 at 10:22 AM

I hope i can fix this problem because i currently can not replicate the problem. I have opened a issue in the issue tracker, to provide you beta version A First Fix is online

http://dnnckeditor.codeplex.com/WorkItem/View.aspx?WorkItemId=3396

Jan 7, 2010 at 3:40 PM

I was able to reproduce the Bug on my Windows 7 DNN Installation.

And fixed it, try the attachment

http://dnnckeditor.codeplex.com/WorkItem/View.aspx?WorkItemId=3396